QueryRowFormat Enumeration
Specifies the format of the rows returned by the query
and restartQuery
methods of
IModelConnection, IModelDb, and ECDb.
extensions
Members
Name | Value | Description |
---|---|---|
UseECSqlPropertyNames | 0 | Each row is an object in which each non-null column value can be accessed by its name as defined in the ECSql. Null values are omitted. |
UseECSqlPropertyIndexes | 1 | Each row is an array of values accessed by an index corresponding to the property's position in the ECSql SELECT statement. Null values are included if they are followed by a non-null column, but trailing null values at the end of the array are omitted. |
UseJsPropertyNames | 2 | Each row is an object in which each non-null column value can be accessed by a remapped property name. This format is backwards-compatible with the format produced by iTwin.js 2.x. Null values are omitted. |
Defined in
Last Updated: 20 June, 2023