BaseReaderOptions Interface
Config for all request made to concurrent query engine.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
priority | undefined | number | Determine priority of this query default to 0, used as hint and can be overriden by backend. | |
quota | undefined | QueryQuota | Restrict time or memory for query but use as hint and may be changed base on backend settings | |
restartToken | undefined | string | If specified cancel last query (if any) with same restart token and queue the new query | |
usePrimaryConn | undefined | boolean | For editing apps this can be set to true and all query will run on primary connection |
Defined in
Last Updated: 20 June, 2023