HiddenLine Namespace
Namespace containing types controlling how edges and surfaces should be drawn in "hidden line" and "solid fill" RenderModes.
Class
Name | Description |
---|---|
HiddenLine.Settings | Describes how visible and hidden edges and transparent surfaces should be rendered in "hidden line" and "solid fill" RenderModes. |
HiddenLine.Style | Describes the symbology with which edges should be drawn. |
Interface
Name | Description |
---|---|
HiddenLine.SettingsProps | The JSON representation of a HiddenLine.Settings. |
HiddenLine.StyleProps | Describes the symbology with which edges should be drawn. |
Defined in
- core/common/src/HiddenLine.ts Line 16
Last Updated: 20 June, 2023