GeometryParams Class
Describes the display properties of graphics in a persistent element's GeometryStream that aren't inherited from SubCategoryAppearance.
see GeometryStreamProps.
Methods
Name | Description | |
---|---|---|
constructor(categoryId: string, subCategoryId: string = Id64.invalid): GeometryParams | Create a GeometryParams given a Category Id for a GeometricElement and optional SubCategory Id. | |
clone(): GeometryParams | ||
isEquivalent(other: GeometryParams): boolean | Compare two GeometryParams for equivalence, i.e. | |
resetAppearance(): void | Clears SubCategoryAppearance overrides while preserving GeometryParams.categoryId and GeometryParams.subCategoryId. | |
setCategoryId(categoryId: string, clearAppearanceOverrides: boolean = true): void | Change GeometryParams.categoryId to the supplied id, GeometryParams.subCategoryId to the supplied category's the default subCategory, and optionally clear any SubCategoryAppearance overrides. | |
setSubCategoryId(subCategoryId: string, clearAppearanceOverrides: boolean = true): void | Change GeometryParams.subCategoryId to the supplied id and optionally clear any SubCategoryAppearance overrides. |
Properties
Name | Type | Description | |
---|---|---|---|
backgroundFill | undefined | BackgroundFill | Optional fill using the current view background color for region interiors. | |
categoryId | string | ||
elmPriority | undefined | number | Optional display priority added to SubCategoryAppearance.priority. | |
elmTransparency | undefined | number | Optional line color transparency to combine with SubCategoryAppearance.transparency. | |
fillColor | undefined | ColorDef | Optional fill color for region interiors. | |
fillDisplay | undefined | FillDisplay | Optional fill specification that determines when and if a region interior will display using GeometryParams.gradient, GeometryParams.backgroundFill, or GeometryParams.fillColor in that order of preference. | |
fillTransparency | undefined | number | Optional fill color transparency to combine with SubCategoryAppearance.transparency. | |
geometryClass | undefined | GeometryClass | Optional geometry classification that can be toggled off with a ViewFlags independent of SubCategoryAppearance.invisible. | |
gradient | undefined | Gradient.Symb | Optional gradient fill settings for region interiors. | |
lineColor | undefined | ColorDef | Optional line color to override SubCategoryAppearance.color. | |
materialId | undefined | string | Optional render material to override SubCategoryAppearance.materialId. | |
pattern | undefined | AreaPattern.Params | Optional area pattern settings for region interiors. | |
styleInfo | undefined | LineStyle.Info | Optional line style to override SubCategoryAppearance.styleId plus modifiers to override the line style definition. | |
subCategoryId | string | ||
weight | undefined | number | Optional line weight to override SubCategoryAppearance.weight. |
Defined in
Last Updated: 20 June, 2023