CloudStorageTileCache Class
Deprecated in 3.x. Use TileStorage (frontend) and TileStorage (backend) instead.
Beta
Extends
- CloudStorageCache<TileContentIdentifier, Uint8Array>
Methods
Name | Description | |
---|---|---|
constructor(): CloudStorageTileCache Protected | ||
formContainerKey(id: TileContentIdentifier): string Protected | ||
formContainerName(id: TileContentIdentifier): string | ||
formResourceName(id: TileContentIdentifier): string | ||
instantiateResource(response: Response): Promise<undefined | Uint8Array> Protected | ||
obtainContainerUrl(id: TileContentIdentifier, descriptor: CloudStorageContainerDescriptor): Promise<CloudStorageContainerUrl> Protected | ||
supplyExpiryForContainerUrl(_id: CloudStorageContainerDescriptor): Date | ||
getCache(): CloudStorageTileCache Static |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getContainer(id: TileContentIdentifier): Promise<CloudStorageContainerUrl> Protected | CloudStorageCache<TileContentIdentifier, Uint8Array> | |
requestResource(container: CloudStorageContainerUrl, id: TileContentIdentifier): Promise<Response> Protected | CloudStorageCache<TileContentIdentifier, Uint8Array> | |
retrieve(id: TileContentIdentifier): Promise<undefined | Uint8Array> | CloudStorageCache<TileContentIdentifier, Uint8Array> | |
supplyUrlBase(_container: CloudStorageContainerUrl, _id: TileContentIdentifier): undefined | string Protected | CloudStorageCache<TileContentIdentifier, Uint8Array> |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
provider | CloudStorageProvider | CloudStorageCache<TileContentIdentifier, Uint8Array> |
Defined in
Last Updated: 20 June, 2023