ViewFlagProps Interface
JSON representation of ViewFlags. This is a persistence format with some unfortunate quirks that have been retained for backwards compatibility. In particular, it supplies three separate flags intended to control lighting - ViewFlagProps.noCameraLights, ViewFlagProps.noSourceLights, and ViewFlagProps.noSolarLight - but there exists only a single ViewFlags.lighting flag. ViewFlags.lighting is set to true unless all three of the "no lighting" flags are true. It also uses awkward negative (ViewFlagProps.noConstruct, ViewFlagProps.noTransp) and/or abbreviated (ViewFlagProps.clipVol, ViewFlagProps.visEdges) property names that differ from those of the corresponding ViewFlags properties, making usage of this type in code error-prone. Prefer to use ViewFlagsProperties unless you need to work directly with the persistence format.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
acs | undefined | boolean | If true, display graphics representing the AuxCoordSystem. | |
ambientOcclusion | undefined | boolean | If true, apply ViewFlagProps.AmbientOcclusion. | |
backgroundMap | undefined | boolean | Display a background map. | |
clipVol | undefined | boolean | If true, apply the view's clipping volume. | |
forceSurfaceDiscard | undefined | boolean | Controls whether surface discard is always applied regardless of other ViewFlags. | |
grid | undefined | boolean | If true, display a grid in the view. | |
hidEdges | undefined | boolean | If true, display the edges of surfaces, even if they are behind other geometry. | |
monochrome | undefined | boolean | If true, apply the view's DisplayStyleSettings.monochromeColor and DisplayStyleSettings.monochromeMode to produce a monochrome image. | |
noCameraLights | undefined | boolean | See ViewFlagProps for how this affects ViewFlags.lighting. | |
noConstruct | undefined | boolean | If true, don't display geometry of class GeometryClass.Construction. | |
noDim | undefined | boolean | If true, don't display geometry of class GeometryClass.Dimension. | |
noFill | undefined | boolean | If true, don't show filled planar regions, unless they use FillFlags.Always. | |
noMaterial | undefined | boolean | If true, don't apply RenderMaterials to surfaces. | |
noPattern | undefined | boolean | If true, don't display geometry of class GeometryClass.Pattern. | |
noSolarLight | undefined | boolean | See ViewFlagProps for how this affects ViewFlags.lighting. | |
noSourceLights | undefined | boolean | See ViewFlagProps for how this affects ViewFlags.lighting. | |
noStyle | undefined | boolean | If true, don't apply LinePixels styles. | |
noTexture | undefined | boolean | If true, don't apply RenderTextures to surfaces. | |
noTransp | undefined | boolean | If true, display transparency geometry as opaque. | |
noWeight | undefined | boolean | If true, all lines are drawn with a width of 1 pixel. | |
noWhiteOnWhiteReversal | undefined | boolean | Disables the "white-on-white reversal" employed by some CAD applications. | |
renderMode | undefined | RenderMode | The basic rendering mode, which affects the behavior of other flags. | |
shadows | undefined | boolean | If true, display shadows. | |
thematicDisplay | undefined | boolean | If true, apply ThematicDisplay. | |
visEdges | undefined | boolean | If true, display the edges of surfaces. | |
wiremesh | undefined | boolean | If true, overlay surfaces with wiremesh to reveal their triangulation. |
Defined in
- core/common/src/ViewFlags.ts Line 55
Last Updated: 20 June, 2023