PhysicalElementProps Interface
Properties that define a PhysicalElement
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
physicalMaterial | undefined | RelatedElementProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | string | GeometricElement3dProps | The id of the category for this geometric element. |
classFullName | string | GeometricElement3dProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | GeometricElement3dProps | The Code for this element |
elementGeometryBuilderParams | undefined | | GeometricElement3dProps | How to build the element's GeometryStream. |
federationGuid | undefined | string | GeometricElement3dProps | A FederationGuid assigned to this element. |
geom | undefined | GeometryStreamProps | GeometricElement3dProps | The geometry stream properties |
id | undefined | string | GeometricElement3dProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricElement3dProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | any | GeometricElement3dProps | Optional json properties of this element. |
model | string | GeometricElement3dProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | GeometricElement3dProps | The Parent of this element, if defined. |
placement | undefined | Placement3dProps | GeometricElement3dProps | The placement properties |
typeDefinition | undefined | RelatedElementProps | GeometricElement3dProps | |
userLabel | undefined | string | GeometricElement3dProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 170
Last Updated: 20 June, 2023