GeometricElement3dProps Interface
Properties that define a GeometricElement3d
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
placement | undefined | Placement3dProps | The placement properties | |
typeDefinition | undefined | RelatedElementProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | string | GeometricElementProps | The id of the category for this geometric element. |
classFullName | string | GeometricElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | GeometricElementProps | The Code for this element |
elementGeometryBuilderParams | undefined | | GeometricElementProps | How to build the element's GeometryStream. |
federationGuid | undefined | string | GeometricElementProps | A FederationGuid assigned to this element. |
geom | undefined | GeometryStreamProps | GeometricElementProps | The geometry stream properties |
id | undefined | string | GeometricElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | GeometricElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | any | GeometricElementProps | Optional json properties of this element. |
model | string | GeometricElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | GeometricElementProps | The Parent of this element, if defined. |
userLabel | undefined | string | GeometricElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 161
Last Updated: 20 June, 2023