PlanProjectionSettings Class
Describes how to draw a plan projection model. A plan projection model is a GeometricModel3d whose geometry all lies in a single XY plane, wherein the Z coordinate of the plane may be arbitrary or flexible. Multiple plan projection models can be combined into one view and drawn as "layers" with relative priorities.
see DisplayStyle3dSettings.setPlanProjectionSettings to define plan projection settings for a DisplayStyle3dState.
see GeometricModel3d.isPlanProjection.
Methods
Name | Description | |
---|---|---|
clone(changedProps?: PlanProjectionSettingsProps): PlanProjectionSettings | Create a copy of this PlanProjectionSettings, optionally modifying some of its properties. | |
toJSON(): PlanProjectionSettingsProps | ||
fromJSON(props: undefined | PlanProjectionSettingsProps): undefined | PlanProjectionSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
elevation Readonly | undefined | number | See PlanProjectionSettingsProps.elevation | |
enforceDisplayPriority Readonly | undefined | boolean | See PlanProjectionSettingsProps.enforceDisplayPriority | |
overlay Readonly | boolean | See PlanProjectionSettingsProps.overlay | |
transparency Readonly | undefined | number | See PlanProjectionSettingsProps.transparency |
Defined in
Last Updated: 20 June, 2023