GeodeticDatumProps Interface
This interface represents a geodetic datum. Geodetic datums are based on an ellipsoid. In addition to the ellipsoid definition they are the base for longitude/latitude coordinates. Geodetic datums are the basis for geodetic transformations. Most geodetic datums are defined by specifying the transformation to the common base WGS84 (or local equivalent). The transforms property can contain the definition of the transformation path to WGS84. Sometimes there exists transformation paths direct from one non-WGS84 datum to another non-WGS84. The current model does not allow specifications of these special paths at the moment.
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
additionalTransformPaths | undefined | GeodeticTransformPathProps[] | The optional list of transformation paths to other datum. | |
deprecated | undefined | boolean | If true then indicates the definition is deprecated. | |
description | undefined | string | Description | |
ellipsoid | undefined | GeodeticEllipsoidProps | The full definition of the geodetic ellipsoid associated to the datum. | |
ellipsoidId | undefined | string | The key name to the base Ellipsoid. | |
epsg | undefined | number | The EPSG code of the geodetic datum. | |
id | undefined | string | GeodeticDatum key name | |
source | undefined | string | A textual description of the source of the geodetic datum definition. | |
transforms | undefined | GeodeticTransformProps[] | The transformation to WGS84. |
Defined in
Last Updated: 20 June, 2023