GeodeticEllipsoidProps Interface
This interface defines the mathematical model of the Earth shape in the form of an ellipsoid. There are various ways to define an ellipsoid but we have retained the definition based on the polar and equatorial radiuses. The other ellipsoid properties, such as flattening and inverse flattening, can be obtained using the simple equations that are defined at: https://en.wikipedia.org/wiki/Flattening and https://en.wikipedia.org/wiki/Earth_ellipsoid.
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
deprecated | undefined | boolean | If true then indicates the definition is deprecated. | |
description | undefined | string | Description of the ellipsoid | |
epsg | undefined | number | The EPSG code of the ellipsoid. | |
equatorialRadius | undefined | number | The equatorial radius of the ellipsoid in meters | |
id | undefined | string | Ellipsoid key name | |
polarRadius | undefined | number | The polar radius of the ellipsoid in meters | |
source | undefined | string | The textual description of the source of the ellipsoid definition. |
Defined in
Last Updated: 20 June, 2023