GeodeticTransformProps Interface
This interface represents a geodetic transformation that enables transforming longitude/latitude coordinates from one datum to another.
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
geocentric | undefined | GeocentricTransformProps | When method is Geocentric this property contains the geocentric parameters | |
gridFile | undefined | GridFileTransformProps | When method is GridFiles this property contains the grid files parameters | |
method | GeodeticTransformMethod | The method used by the geodetic transform | |
positionalVector | undefined | PositionalVectorTransformProps | When method is PositionalVector this property contains the positional vector parameters | |
sourceDatumId | undefined | string | The id of the source datum. | |
sourceEllipsoid | undefined | GeodeticEllipsoidProps | The complete definition of the source geodetic ellipsoid referred to by ellipsoidId. | |
targetDatumId | undefined | string | The id of the target datum. | |
targetEllipsoid | undefined | GeodeticEllipsoidProps | The complete definition of the target geodetic ellipsoid referred to by ellipsoidId. |
Defined in
Last Updated: 20 June, 2023