ViewDefinition2dProps Interface
Parameters used to construct a ViewDefinition2d
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
angle | AngleProps | ||
baseModelId | string | ||
delta | XYProps | ||
origin | XYProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
categorySelectorId | string | ViewDefinitionProps | |
classFullName | string | ViewDefinitionProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ViewDefinitionProps | The Code for this element |
description | undefined | string | ViewDefinitionProps | |
displayStyleId | string | ViewDefinitionProps | |
federationGuid | undefined | string | ViewDefinitionProps | A FederationGuid assigned to this element. |
id | undefined | string | ViewDefinitionProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ViewDefinitionProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | ViewDefinitionProps | |
jsonProperties | undefined | { viewDetails?: ViewDetailsProps } | ViewDefinitionProps | Optional json properties of this element. |
model | string | ViewDefinitionProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | ViewDefinitionProps | The Parent of this element, if defined. |
userLabel | undefined | string | ViewDefinitionProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 189
Last Updated: 20 June, 2023