TerrainProps Interface
JSON representation of the settings of the terrain applied to background map display by a DisplayStyle.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
applyLighting | undefined | boolean | Applying lighting can help to visualize subtle terrain variation. | |
exaggeration | undefined | number | A value greater than one will cause terrain height to be exaggerated/scaled.false (or 1.0) indicate no exaggeration. | |
heightOrigin | undefined | number | Origin value - height of the IModel origin at the project center as defined by heightOriginMode. | |
heightOriginMode | undefined | TerrainHeightOriginMode | Determines how/if the heightOrigin is applied to the terrain height. | |
providerName | undefined | string | Identifies the TerrainProvider that will supply terrain meshes. |
Defined in
Last Updated: 20 June, 2023