TerrainProvider Interface
Beta
Interface adopted by an object that can supply TerrainMeshProviders enabling the display of 3d terrain in a Viewport.
see TerrainProviderRegistry to register or look up a TerrainProvider
by its name.
see TerrainSettings.providerName to specify the terrain provider used by a DisplayStyle.
Methods
Name | Description | |
---|---|---|
createTerrainMeshProvider(options: TerrainMeshProviderOptions): Promise<undefined | TerrainMeshProvider> | Produce a TerrainMeshProvider using the specified options. |
Defined in
Last Updated: 20 June, 2023