TerrainProviderRegistry Class
Beta
A registry of TerrainProviders identified by their unique names. The registry can be accessed via IModelApp.terrainProviderRegistry. It always includes the built-in provider named "CesiumWorldTerrain", which obtains terrain meshes from Cesium ION. That provider requires a valid TileAdmin.Props.cesiumIonKey to be supplied to IModelApp.startup. Any number of additional providers can be TerrainProviderRegistry.registered.
When terrain is enabled for a Viewport, the display system will attempt to look up the TerrainProvider corresponding to the TerrainSettings.providerName specified by the Viewport's DisplayStyleSettings. If a provider by that name is registered, it will be used to obtain terrain meshes; otherwise, the display system will produce flat terrain meshes.
Methods
Name | Description | |
---|---|---|
find(name: string): undefined | TerrainProvider | Look up a TerrainProviderRegistry.registered TerrainProvider by its name. | |
register(name: string, provider: TerrainProvider): void | Register a new TerrainProvider. |
Defined in
Last Updated: 20 June, 2023