TerrainMeshProvider Class
Beta
Provides 3d meshes representing terrain for display in a Viewport.
Each mesh represents the terrain within a rectangular region of the Earth associated with a MapTile.
The display system drapes background map imagery onto these meshes.
TerrainMeshProvider
s are obtained from TerrainProviders.
Methods
Name | Description | |
---|---|---|
constructor(): TerrainMeshProvider | ||
addLogoCards(_cards: HTMLTableElement, _vp: ScreenViewport): void | Add attribution logo cards for the terrain data supplied by this provider to the Viewport's logo div. | |
forceTileLoad(_tile: MapTile): boolean | Returns true if the specified tile should always be loaded. | |
getChildHeightRange(quadId: QuadId, rectangle: MapCartoRectangle, parent: MapTile): undefined | Range1d | Returns the minimum and maximum elevation of the terrain within the specified region of the Earth. | |
isTileAvailable(_quadId: QuadId): boolean | Return whether terrain data can be obtained for the MapTile specified by quadId . |
|
readMesh(args: ReadMeshArgs): Promise<undefined | RealityMeshParams> Abstract | Convert the terrain data supplied by TerrainMeshProvider.requestMeshData into a terrain mesh. | |
requestMeshData(args: RequestMeshDataArgs): Promise<any> Abstract | Obtain a representation of the terrain for a specific MapTile. |
Properties
Name | Type | Description | |
---|---|---|---|
maxDepth Accessor AbstractReadOnly | number | Returns the maximum level of detail of the terrain meshes. | |
tilingScheme Accessor AbstractReadOnly | MapTilingScheme | The tiling scheme used by this provider to convert between tile coordinates and geodetic coordinates. |
Defined in
Last Updated: 20 June, 2023