QuadId Class
Beta
Identifies a node within a quad tree, such as a MapTile within a MapTileTree. A quad tree recursively sub-divides a two-dimensional space along the X and Y axes such that each node on level L has four child nodes on level L+1.
Methods
Name | Description | |
---|---|---|
constructor(level: number, column: number, row: number): QuadId | Construct a new QuadId. | |
bordersNorthPole(mapTilingScheme: MapTilingScheme): boolean | Returns true if this node is adjacent to the north pole according to the specified tiling scheme. | |
bordersSouthPole(mapTilingScheme: MapTilingScheme): boolean | Returns true if this node is adjacent to the south pole according to the specified tiling scheme. | |
compare(other: QuadId): number | Compares this Id to another according to the conventions of an OrderedComparator. | |
getChildIds(columnCount: number = 2, rowCount: number = 2): QuadId[] | Compute the QuadIds corresponding to this node's four child nodes. | |
getLatLongRangeDegrees(mapTilingScheme: MapTilingScheme): Range2d | Compute the region of the surface of the Earth represented by this node according to the specified tiling scheme. | |
getLatLongRangeRadians(mapTilingScheme: MapTilingScheme): Range2d | Compute the region of the surface of the Earth represented by this node according to the specified tiling scheme. |
Properties
Defined in
Last Updated: 20 June, 2023