BackgroundMapProps Interface
In-memory JSON representation of a BackgroundMapSettings.
see PersistentBackgroundMapProps for the persistent JSON representation.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
applyTerrain | undefined | boolean | If true, terrain heights will be applied to the map; otherwise the map will be rendered as a plane. | |
globeMode | undefined | GlobeMode | Globe Mode. | |
groundBias | undefined | number | The elevation of the map in meters relative the WGS84 ellipsoid. | |
nonLocatable | undefined | boolean | If true, the map will be treated as non-locatable - i.e., tools will not interact with it. | |
planarClipMask | undefined | PlanarClipMaskProps | A planar mask applied to the map geometry | Beta |
providerData | undefined | undefined | See DeprecatedBackgroundMapProps.providerData. | |
providerName | undefined | undefined | See DeprecatedBackgroundMapProps.providerName. | |
terrainSettings | undefined | TerrainProps | Properties associated with terrain display. | |
transparency | number | | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, or false to indicate the transparency should not be overridden. | |
useDepthBuffer | undefined | boolean | If set to true, the map tiles will be rendered with depth, allowing them to obscure other geometry. |
Defined in
Last Updated: 20 June, 2023