BentleyCloudRpcManager Class
Beta
Coordinates usage of RPC interfaces for Bentley cloud deployments.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): BentleyCloudRpcManager | ||
initializeClient(params: BentleyCloudRpcParams, interfaces: RpcInterfaceDefinition<RpcInterface>[], routing: RpcRoutingToken = RpcRoutingToken.default): BentleyCloudRpcConfiguration Static | Beta | |
initializeImpl(params: BentleyCloudRpcParams, interfaces: RpcInterfaceDefinition<RpcInterface>[]): BentleyCloudRpcConfiguration Static | Beta |
Inherited methods
Name | Inherited from | Description |
---|---|---|
describeAvailableEndpoints(): Promise<RpcInterfaceEndpoints[]> Static | RpcManager | Describes the RPC interfaces and endpoints that are currently available from the backend. |
getClientForInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingToken = RpcRoutingToken.default): T Static | RpcManager | Returns the RPC client instance for the frontend. |
initializeInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>): void Static | RpcManager | Initializes an RPC interface class. |
registerImpl<TDefinition extends RpcInterface<TDefinition>, TImplementation extends RpcInterface<TImplementation>>(definition: RpcInterfaceDefinition<TDefinition>, implementation: RpcInterfaceImplementation<TImplementation>): void Static | RpcManager | Register the RPC implementation class for the backend. |
setIModel(props: IModelRpcProps): void Static | RpcManager | Configures RPC protocols that employ iModel-based routing infrastructure. |
supplyImplInstance<TDefinition extends RpcInterface<TDefinition>, TImplementation extends RpcInterface<TImplementation>>(definition: RpcInterfaceDefinition<TDefinition>, instance: TImplementation): void Static | RpcManager | Supply the instance of the RPC interface implementation class for the backend (optional). |
terminateInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>): void Static | RpcManager | Terminates an RPC interface class. |
unregisterImpl<TDefinition extends RpcInterface<TDefinition>>(definition: RpcInterfaceDefinition<TDefinition>): void Static | RpcManager | Unregister the RPC implementation class for the backend. |
Defined in
Last Updated: 20 June, 2023