RpcManager Class
Beta
RPC interface management is concerned with coordination of access and configuration for RPC interfaces.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RpcManager | ||
describeAvailableEndpoints(): Promise<RpcInterfaceEndpoints[]> Static | Describes the RPC interfaces and endpoints that are currently available from the backend. | |
getClientForInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>, routing: RpcRoutingToken = RpcRoutingToken.default): T Static | Returns the RPC client instance for the frontend. | |
initializeInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>): void Static | Initializes an RPC interface class. | |
registerImpl<TDefinition extends RpcInterface<TDefinition>, TImplementation extends RpcInterface<TImplementation>>(definition: RpcInterfaceDefinition<TDefinition>, implementation: RpcInterfaceImplementation<TImplementation>): void Static | Register the RPC implementation class for the backend. | |
setIModel(props: IModelRpcProps): void Static | Configures RPC protocols that employ iModel-based routing infrastructure. | |
supplyImplInstance<TDefinition extends RpcInterface<TDefinition>, TImplementation extends RpcInterface<TImplementation>>(definition: RpcInterfaceDefinition<TDefinition>, instance: TImplementation): void Static | Supply the instance of the RPC interface implementation class for the backend (optional). | |
terminateInterface<T extends RpcInterface<T>>(definition: RpcInterfaceDefinition<T>): void Static | Terminates an RPC interface class. | |
unregisterImpl<TDefinition extends RpcInterface<TDefinition>>(definition: RpcInterfaceDefinition<TDefinition>): void Static | Unregister the RPC implementation class for the backend. |
Defined in
- core/common/src/RpcManager.ts Line 30
Last Updated: 20 June, 2023