IModelRpcProps Interface
The properties that identify an opened iModel for RPC operations.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
key Readonly | string | Unique key used for identifying the iModel between the frontend and the backend |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
changeset Readonly | undefined | ChangesetIdWithIndex | IModelRpcOpenProps | Id of the last Changeset that was applied to the iModel - must be defined for briefcases that are synchronized with iModelHub. |
iModelId Readonly | undefined | string | IModelRpcOpenProps | Guid of the iModel. |
iTwinId Readonly | undefined | string | IModelRpcOpenProps | The iTwin in which the iModel exists - must be defined for briefcases that are synchronized with iModelHub. |
Defined in
- core/common/src/IModel.ts Line 39
Last Updated: 20 June, 2023