ChannelRootAspect Class
A ChannelRootAspect identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained.
note The associated ECClass was added to the BisCore schema in version 1.0.10
Extends
Methods
Name | Description | |
---|---|---|
insert(iModel: IModelDb, ownerId: string, ownerDescription: string): void Static | Insert a ChannelRootAspect on the specified element. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | ElementUniqueAspect | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | ElementUniqueAspect | Call a function for each property of this Entity. |
getReferenceIds(): Set<string> | ElementUniqueAspect | Get the Ids of this element's references. |
is(otherClass: undefined): boolean Static | ElementUniqueAspect | return whether this Entity class is a subclass of another Entity class |
onDelete(_arg: OnAspectIdArg): void ProtectedStatic | ElementUniqueAspect | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void ProtectedStatic | ElementUniqueAspect | Called after an ElementAspect was deleted. |
onInsert(_arg: OnAspectPropsArg): void ProtectedStatic | ElementUniqueAspect | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void ProtectedStatic | ElementUniqueAspect | Called after a new ElementAspect was inserted. |
onUpdate(_arg: OnAspectPropsArg): void ProtectedStatic | ElementUniqueAspect | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void ProtectedStatic | ElementUniqueAspect | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
owner | string | The owner of the channel |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | ElementUniqueAspect | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | ElementUniqueAspect | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | ElementUniqueAspect | The name of the BIS class associated with this class. |
element | RelatedElement | ElementUniqueAspect | |
id | string | ElementUniqueAspect | The Id of this Entity. |
iModel | IModelDb | ElementUniqueAspect | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | ElementUniqueAspect | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static | undefined | ElementUniqueAspect | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | ElementUniqueAspect | The name of the BIS Schema that defines this class |
Defined in
- backend/src/ElementAspect.ts Line 120
Last Updated: 20 June, 2023