QPoint2dBuffer Namespace
Function
Name | Description |
---|---|
QPoint2dBuffer.getQPoint | Extracts the point at the specified index from a buffer. |
QPoint2dBuffer.unquantizePoint | Extracts and unquantizes the point at the specified index from a buffer. |
Defined in
- core/common/src/QPoint.ts Line 253
QPoint2dBuffer Interface
A compact representation of a list of QPoint2ds stored in a Uint16Array
This representation is particularly useful when passing data to WebGL; for example, see RealityMeshParams.uvs.
see QPoint3dBuffer for 3d points.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
params | QParams2d | The parameters used to quantize the QPoint2dBuffer.points. | |
points | Uint16Array | The QPoint2ds as pairs of unsigned 16-bit integers. |
Defined in
- core/common/src/QPoint.ts Line 241
Last Updated: 20 June, 2023