EntityQueryParams Interface
Parameters for performing a query on Entity classes.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
bindings | object | any[] | Bindings for parameterized values. | |
from | undefined | string | The sql className, in the form "Schema.ClassName", of the class to search. | |
limit | undefined | number | Optional "LIMIT" clause to limit the number of rows returned. | |
offset | undefined | number | Optional "OFFSET" clause. | |
only | undefined | boolean | Set to true to limit results to not include sub-classes of "from" class | |
orderBy | undefined | string | Optional "ORDERBY" clause to sort results. | |
where | undefined | string | Optional "WHERE" clause to filter entities. |
Defined in
- core/common/src/EntityProps.ts Line 53
Last Updated: 20 June, 2023