TextureData Interface
Information about Texture data returned by IModelReadRpcInterface.queryTextureData.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
bytes | Uint8Array | The encoded image bytes. | |
format | ImageSourceFormat | The format of the image (Jpeg or Png). | |
height | number | The height of the image, possibly reduced from the original height based on TextureLoadProps.maxTextureSize. | |
transparency | undefined | TextureTransparency | Information about the transparency of the texture image. | |
width | number | The width of the image, possibly reduced from the original width based on TextureLoadProps.maxTextureSize. |
Defined in
- core/common/src/TextureProps.ts Line 63
Last Updated: 20 June, 2023