SkyCube Class
Describes how to draw a representation of a sky by mapping images to the interior faces of a cube.
The images are required to be square, and each image must have the same dimensions as the other images.
Extends
Methods
Inherited methods
Properties
Name |
Type |
Description |
|
images Readonly |
SkyCubeProps |
The images to map to each face of the cube. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
defaults StaticReadonly |
SkyBox |
SkyBox |
Default settings for a four-color gradient. |
gradient Readonly |
SkyGradient |
SkyBox |
The gradient settings, used if no cube or sphere images are supplied, or if the images cannot be loaded. |
Defined in
Last Updated:
20 June, 2023