Cartographic Class
A position on the earth defined by longitude, latitude, and height above the WGS84 ellipsoid.
Implements
Methods
Name | Description | |
---|---|---|
clone(result?: Cartographic): Cartographic | Duplicates a Cartographic. | |
equals(right: CartographicProps): boolean | Return true if this Cartographic is the same as right | |
equalsEpsilon(right: CartographicProps, epsilon: number): boolean | Compares this Cartographic component-wise and returns true if they are within the provided epsilon, | |
freeze(): Readonly<Cartographic> | Freeze this Cartographic | |
toEcef(result?: Point3d): Point3d | Return an ECEF point from a Cartographic point | |
toJSON(): CartographicProps | Create a JSON representation of a Cartographic object. | |
toString(): string | Create a string representing this cartographic in the format '(longitude, latitude, height)'. | |
createZero(): Cartographic Static | Create a Cartographic object with longitude, latitude, and height of zero. | |
fromAngles(args: { height?: number, latitude: Angle, longitude: Angle }, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude in Angles. | |
fromDegrees(args: { height?: number, latitude: number, longitude: number }, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude specified in degrees. | |
fromEcef(cartesian: Point3d, result?: Cartographic): undefined | Cartographic Static | Creates a new Cartographic from an ECEF position. | |
fromRadians(args: { height?: number, latitude: number, longitude: number }, result?: Cartographic): Cartographic Static | Create a new Cartographic from longitude and latitude specified in radians. | |
geocentricLatitudeFromGeodeticLatitude(geodeticLatitude: number): number Static | return the geocentric latitude angle for the input geodetic latitude angle (both in radians). | |
parametricLatitudeFromGeodeticLatitude(geodeticLatitude: number): number Static | return the parametric latitude angle for the input geodetic latitude angle (both in radians). | |
scalePointToGeodeticSurface(point: Point3d, result?: Point3d): undefined | Point3d Static | Scale point to geodetic surface |
Properties
Defined in
Last Updated: 20 June, 2023