PropertyMetaData Class
Beta
Metadata for a property.
Implements
Methods
Name | Description | |
---|---|---|
constructor(jsonObj: PropertyMetaDataProps): PropertyMetaData | ||
createProperty(jsonObj: any): any | construct a single property from an input object according to this metadata |
Properties
Name | Type | Description | |
---|---|---|---|
customAttributes | undefined | CustomAttribute[] | ||
description | undefined | string | ||
direction | undefined | string | ||
displayLabel | undefined | string | ||
extendedType | undefined | string | ||
isCustomHandled | undefined | boolean | ||
isCustomHandledOrphan | undefined | boolean | ||
isNavigation Accessor ReadOnly | boolean | Return true if this property is a NavigationProperty. |
|
kindOfQuantity | undefined | string | ||
maximumLength | undefined | number | ||
maximumValue | undefined | any | ||
maxOccurs | undefined | number | ||
minimumLength | undefined | number | ||
minimumValue | undefined | any | ||
minOccurs | undefined | number | ||
primitiveType | undefined | PrimitiveTypeCode | ||
readOnly | undefined | boolean | ||
relationshipClass | undefined | string | ||
structName | undefined | string |
Defined in
- core/common/src/EntityProps.ts Line 131
Last Updated: 20 June, 2023