IpcSocketFrontend Interface
Interface for the frontend (browser) side of a socket connection. Frontends may invoke methods implemented on the backend.
Extends
Methods
Name | Description | |
---|---|---|
invoke(channel: string, ...args: any[]): Promise<any> | Send a message to the backend via channel and expect a result asynchronously. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
addListener(channel: string, listener: IpcListener): RemoveFunction | IpcSocket | Establish a handler to receive messages for a channel through a socket. |
removeListener(channel: string, listener: IpcListener): void | IpcSocket | Remove a previously registered listener |
send(channel: string, ...data: any[]): void | IpcSocket | Send a message over the socket. |
Defined in
- core/common/src/ipc/IpcSocket.ts Line 69
Last Updated: 20 June, 2023