IModelStatus Enumeration
Status codes that are used in conjunction with BentleyError.
Error status codes are divided into separate ranges for different kinds of errors. All known ranges at least should be defined here, to avoid collisions.
Members
Name |
Value |
Description |
Success |
0 |
|
IMODEL_ERROR_BASE |
65536 |
|
AlreadyLoaded |
65537 |
|
AlreadyOpen |
65538 |
|
BadArg |
65539 |
|
BadElement |
65540 |
|
BadModel |
65541 |
|
BadRequest |
65542 |
|
BadSchema |
65543 |
|
CannotUndo |
65544 |
|
CodeNotReserved |
65545 |
|
DeletionProhibited |
65546 |
|
DuplicateCode |
65547 |
|
DuplicateName |
65548 |
|
ElementBlockedChange |
65549 |
|
FileAlreadyExists |
65550 |
|
FileNotFound |
65551 |
|
FileNotLoaded |
65552 |
|
ForeignKeyConstraint |
65553 |
|
IdExists |
65554 |
|
InDynamicTransaction |
65555 |
|
InvalidCategory |
65556 |
|
InvalidCode |
65557 |
|
InvalidCodeSpec |
65558 |
|
InvalidId |
65559 |
|
InvalidName |
65560 |
|
InvalidParent |
65561 |
|
InvalidProfileVersion |
65562 |
|
IsCreatingChangeSet |
65563 |
|
LockNotHeld |
65564 |
|
Mismatch2d3d |
65565 |
|
MismatchGcs |
65566 |
|
MissingDomain |
65567 |
|
MissingHandler |
65568 |
|
MissingId |
65569 |
|
NoGeometry |
65570 |
|
NoMultiTxnOperation |
65571 |
|
NotEnabled |
65573 |
|
NotFound |
65574 |
|
NotOpen |
65575 |
|
NotOpenForWrite |
65576 |
|
NotSameUnitBase |
65577 |
|
NothingToRedo |
65578 |
|
NothingToUndo |
65579 |
|
ParentBlockedChange |
65580 |
|
ReadError |
65581 |
|
ReadOnly |
65582 |
|
ReadOnlyDomain |
65583 |
|
RepositoryManagerError |
65584 |
|
SQLiteError |
65585 |
|
TransactionActive |
65586 |
|
UnitsMissing |
65587 |
|
UnknownFormat |
65588 |
|
UpgradeFailed |
65589 |
|
ValidationFailed |
65590 |
|
VersionTooNew |
65591 |
|
VersionTooOld |
65592 |
|
ViewNotFound |
65593 |
|
WriteError |
65594 |
|
WrongClass |
65595 |
|
WrongIModel |
65596 |
|
WrongDomain |
65597 |
|
WrongElement |
65598 |
|
WrongHandler |
65599 |
|
WrongModel |
65600 |
|
ConstraintNotUnique |
65601 |
|
NoGeoLocation |
65602 |
|
ServerTimeout |
65603 |
|
NoContent |
65604 |
|
NotRegistered |
65605 |
|
FunctionNotFound |
65606 |
|
NoActiveCommand |
65607 |
|
Defined in
Last Updated:
20 June, 2023