Helmert2DWithZOffsetProps Interface
An affine transformation with an additional Z Offset. The equations are: given a = scale * cos(rotation) and b = scale * sin(rotation) X = a * x - b * y + translationX Y = b * x + a * y + translationY Z = z + translationZ
extensions
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
rotDeg | number | The rotation in the trigonometric (CCW) direction in degrees. | |
scale | number | The scale. | |
translationX | number | The X post translation | |
translationY | number | The Y post-translation | |
translationZ | number | The Z post-translation or Z offset |
Defined in
Last Updated: 20 June, 2023