RenderSchedule Namespace
Namespace containing types that collectively define a script that animates the contents of a view by adjusting the visibility, position, and/or symbology of groups of elements over time. A RenderSchedule.Script is hosted by a RenderTimeline element. The script can be associated with a DisplayStyleState by way of its DisplayStyleSettings.renderTimeline property.
Enumeration
Name | Description |
---|---|
RenderSchedule.Interpolation | Defines how two interpolate between two entries in a RenderSchedule.Timeline. |
Class
Name | Description |
---|---|
RenderSchedule.ColorEntry | A timeline entry controlling the color of the affected geometry. |
RenderSchedule.CuttingPlane | Defines a ClipPlane associated with a RenderSchedule.CuttingPlaneEntry. |
RenderSchedule.CuttingPlaneEntry | A timeline entry that applies a ClipPlane to the affected geometry. |
RenderSchedule.ElementTimeline | Specifies how to animate the geometry belonging to a set of GeometricElements as part of a RenderSchedule.Script. |
RenderSchedule.ElementTimelineBuilder | As part of a RenderSchedule.ScriptBuilder, assembles a RenderSchedule.ElementTimeline. |
RenderSchedule.ModelTimeline | Specifies how to animate the geometry within a GeometricModel as part of a RenderSchedule.Script. |
RenderSchedule.ModelTimelineBuilder | As part of a [[RenderSchedule.ScriptBuilder, assembles a RenderSchedule.ModelTimeline. |
RenderSchedule.Script | Specifies how to animate the contents of a ViewState over time. |
RenderSchedule.ScriptBuilder | Assembles the JSON representation for a new RenderSchedule.Script. |
RenderSchedule.ScriptReference | A reference to a RenderSchedule.Script, optionally identifying the source of the script. |
RenderSchedule.Timeline | Specifies how to animate a set of geometry over time within a RenderSchedule.Script. |
RenderSchedule.TimelineBuilder | Used as part of a RenderSchedule.ScriptBuilder to define a RenderSchedule.Timeline. |
RenderSchedule.TimelineEntry | Describes the value of some property at a specific point along a RenderSchedule.Timeline. |
RenderSchedule.TimelineEntryList | A list of the RenderSchedule.TimelineEntry objects within a RenderSchedule.Timeline. |
RenderSchedule.TransformComponents | Describes the components of a RenderSchedule.TransformEntry as a rotation around a pivot point followed by a translation. |
RenderSchedule.TransformEntry | A timeline entry that applies rotation, scaling, and/or translation to the affected geometry. |
RenderSchedule.TransformTimelineEntries | A list of RenderSchedule.TransformEntrys within a RenderSchedule.Timeline. |
RenderSchedule.VisibilityEntry | A timeline entry that controls the visibility of the associated geometry. |
RenderSchedule.VisibilityTimelineEntries | A list of RenderSchedule.VisibilityEntrys within a RenderSchedule.Timeline. |
Interface
Type alias
Name | Description |
---|---|
RenderSchedule.ScriptProps | JSON representation of a RenderSchedule.Script. |
Defined in
Last Updated: 20 June, 2023