DisplayStyleOverridesOptions Interface
Controls which settings are serialized by DisplayStyleSettings.toOverrides. A display style includes some settings that are specific to a given iModel - for example, the subcategory overrides are indexed by subcategory Ids and model appearance overrides are indexed by model ids. Other settings are specific to a given iTwin, like the set of displayed context reality models. Such settings can be useful when creating display style overrides intended for use with a specific iModel or iTwin, but should be omitted when creating general-purpose display style overrides intended for use with any iModel or iTwin. This is the default behavior if no more specific options are provided.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
includeAll | undefined | "true" | Serialize all settings. | |
includeBackgroundMap | undefined | "true" | Serialize the background map settings. | |
includeDrawingAids | undefined | "true" | Serialize settings related to drawing aid decorations (the ACS triad and the grid). | |
includeIModelSpecific | undefined | "true" | Serialize iModel-specific settings. | |
includeITwinSpecific | undefined | "true" | Serialize iTwin-specific settings. |
Defined in
Last Updated: 20 June, 2023