RealityDataProvider Enumeration
Beta
Identify the Reality Data service provider
Members
Name | Value | Description |
---|---|---|
TilesetUrl | "TilesetUrl" | This is the legacy mode where the access to the 3d tiles is harcoded in ContextRealityModelProps.tilesetUrl property. It was use to support RealityMesh3DTiles, Terrain3DTiles, Cesium3DTiles You should use other mode when possible see createKeyFromUrl that will try to detect provider from an URL |
OrbitGtBlob | "OrbitGtBlob" | This is the legacy mode where the access to the 3d tiles is harcoded in ContextRealityModelProps.OrbitGtBlob property. It was use to support OrbitPointCloud (OPC) from other server than ContextShare You should use other mode when possible see createKeyFromOrbitGtBlobProps that will try to detect provider from an URL |
ContextShare | "ContextShare" | Will provide access url from realityDataId and iTwinId on contextShare for 3dTile storage format or OPC storage format This provider support all type of 3dTile storage fomat and OrbitPointCloud: RealityMesh3DTiles, Terrain3DTiles, Cesium3DTiles, OPC see RealityDataFormat. |
CesiumIonAsset | "CesiumIonAsset" | Will provide Open Street Map Building (OSM) from Cesium Ion (in 3dTile format) |
Defined in
Last Updated: 20 June, 2023