GraphicParams Class
The "cooked" material and symbology for a RenderGraphic. This determines the appearance (e.g. texture, color, width, linestyle, etc.) used to draw Geometry.
Methods
Name | Description | |
---|---|---|
constructor(): GraphicParams | ||
clone(out?: GraphicParams): GraphicParams | ||
setFillTransparency(transparency: number): void | Set the transparency of the fill color, where 0=fully opaque and 255=full transparent. | |
setLineTransparency(transparency: number): void | Set the transparency of the line color, where 0=fully opaque and 255=full transparent. | |
fromBlankingFill(fillColor: ColorDef): GraphicParams Static | Create a GraphicParams with blanking fill of the specified color. | |
fromSymbology(lineColor: ColorDef, fillColor: ColorDef, lineWidth: number, linePixels: LinePixels = LinePixels.Solid): GraphicParams Static | Conveniently create a GraphicParams the most commonly-used properties. |
Properties
Name | Type | Description | |
---|---|---|---|
fillColor | ColorDef | The color of surfaces. | |
fillFlags | FillFlags | Describes how fill is applied to planar regions in wireframe mode. | |
gradient | undefined | Gradient.Symb | Gradient fill applied to surfaces. | |
lineColor | ColorDef | The color of curves and edges. | |
linePixels | LinePixels | The line pattern applied to curves and edges. | |
material | undefined | RenderMaterial | Material applied to surfaces. | |
rasterWidth | number | The width, in pixels, of curves and edges. |
Defined in
- core/common/src/GraphicParams.ts Line 39
Last Updated: 20 June, 2023