DisplayStyle3dProps Interface
JSON representation of a DisplayStyle3d or DisplayStyle3dState.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
jsonProperties | undefined | { styles?: DisplayStyle3dSettingsProps } | Display styles store their settings in a styles property within ElementProps.jsonProperties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | DisplayStyleProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | DisplayStyleProps | The Code for this element |
federationGuid | undefined | string | DisplayStyleProps | A FederationGuid assigned to this element. |
id | undefined | string | DisplayStyleProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | DisplayStyleProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | DisplayStyleProps | |
model | string | DisplayStyleProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | DisplayStyleProps | The Parent of this element, if defined. |
userLabel | undefined | string | DisplayStyleProps | A user-assigned label for this element. |
Defined in
Last Updated: 20 June, 2023