AuxCoordSystem3dProps Interface
Properties of AuxCoordSystem3d
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
origin | undefined | XYZProps | Origin of the AuxCoordSystem3d | |
pitch | undefined | AngleProps | Pitch angle | |
roll | undefined | AngleProps | Roll angle | |
yaw | undefined | AngleProps | Yaw angle |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | AuxCoordSystemProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | AuxCoordSystemProps | The Code for this element |
description | undefined | string | AuxCoordSystemProps | |
federationGuid | undefined | string | AuxCoordSystemProps | A FederationGuid assigned to this element. |
id | undefined | string | AuxCoordSystemProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | AuxCoordSystemProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | any | AuxCoordSystemProps | Optional json properties of this element. |
model | string | AuxCoordSystemProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | AuxCoordSystemProps | The Parent of this element, if defined. |
type | undefined | number | AuxCoordSystemProps | |
userLabel | undefined | string | AuxCoordSystemProps | A user-assigned label for this element. |
Defined in
- core/common/src/ViewProps.ts Line 220
Last Updated: 20 June, 2023