PlanarClipMaskSettings Class
Describes how to mask the geometry of one GeometricModel for display. The mask is produced by projecting geometry from any number of other models - optionally filtered by SubCategory or by a set of specific GeometricElements - onto a plane. Regions of the masked model that intersect the mask are rendered partially or completely transparent. This is useful for, e.g., making subsurface geometry visible below the background map, or clipping out portions of a reality model that intersect a design model.
note Currently reality models (including background maps and terrain) can be masked, but design models can only produce masks.
see DisplayStyleSettings.planarClipMasks to define clip masks for a DisplayStyle.
see ContextRealityModel.planarClipMaskSettings to apply a clip mask to a context reality model.
Methods
Name | Description | |
---|---|---|
clone(changedProps?: PlanarClipMaskProps): PlanarClipMaskSettings | Create a copy of this TerrainSettings, optionally modifying some of its properties. | |
equals(other: PlanarClipMaskSettings): boolean | ||
toJSON(): PlanarClipMaskProps | Create JSON object representing this PlanarClipMaskSettings | |
create(args: ModelPlanarClipMaskArgs | ElementPlanarClipMaskArgs | SubCategoryPlanarClipMaskArgs | PriorityPlanarClipMaskArgs): PlanarClipMaskSettings Static | Create a new PlanarClipMaskSettings. | |
fromJSON(json?: PlanarClipMaskProps): PlanarClipMaskSettings Static | Create a new PlanarClipMaskSettings object from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
compressedModelIds Accessor ReadOnly | undefined | string | The compressed representation of PlanarClipMaskSettings.modelIds. | |
defaults Static | PlanarClipMaskSettings | A default PlanarClipMask which masks nothing. | |
invert Readonly | boolean | A value of true indicates that the mask should be inverted and only content within the mask should be displayed, in other words the area inside the mask is displayed rather than outside. | |
isValid Accessor ReadOnly | boolean | Returns true if masking is enabled. | |
mode Readonly | PlanarClipMaskMode | Specifies how the mask geometry is produced. | |
modelIds Readonly | undefined | OrderedId64Iterable | For any mode other than PlanarClipMaskMode.Priority, the Ids of the GeometricModels containing the geometry used to produce the mask. | |
priority Readonly | undefined | number | For PlanarClipMaskMode.Priority, the priority value. | |
subCategoryOrElementIds Readonly | undefined | OrderedId64Iterable | For PlanarClipMaskMode.IncludeElements or PlanarClipMaskMode.ExcludedElements, the Ids of the GeometricElements to include or exclude from masking; | |
transparency Readonly | undefined | number | A value between 0 and 1 indicating an override for mask transparency. |
Defined in
- core/common/src/PlanarClipMask.ts Line 150
Last Updated: 20 June, 2023