RenderMaterialProps Interface
Properties that define a RenderMaterialElement.
see RenderMaterial for the representation used by the display system.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
description | undefined | string | An optional description of the material. | |
jsonProperties | undefined | { materialAssets?: { renderMaterial?: RenderMaterialAssetProps } } | Optional json properties of this element. | |
paletteName | string | The name of a palette that can be used to categorize multiple materials. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | DefinitionElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | DefinitionElementProps | The Code for this element |
federationGuid | undefined | string | DefinitionElementProps | A FederationGuid assigned to this element. |
id | undefined | string | DefinitionElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | DefinitionElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | undefined | boolean | DefinitionElementProps | |
model | string | DefinitionElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | DefinitionElementProps | The Parent of this element, if defined. |
userLabel | undefined | string | DefinitionElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/MaterialProps.ts Line 157
Last Updated: 20 June, 2023