TxnChangedEntities Interface
Describes a set of Elements or Models that changed as part of a transaction.
see TxnManager.onElementsChanged and TxnManager.onModelsChanged.
Properties
Name | Type | Description | |
---|---|---|---|
deletes Readonly | EntityIdAndClassIdIterable | The entities that were deleted by the transaction. | |
inserts Readonly | EntityIdAndClassIdIterable | The entities that were inserted by the transaction. | |
updates Readonly | EntityIdAndClassIdIterable | The entities that were modified by the transaction, including any Elements for which one of their ElementAspects was changed. |
Defined in
- backend/src/TxnManager.ts Line 41
Last Updated: 20 June, 2023