ModelClipGroup Class
Describes how to clip a group of models in the context of a ViewDefinition3d by applying a single [ClipVector]($core-geometry] to each model in the group.
see ModelClipGroups to define multiple groups of models with different clip vectors.
Methods
Name | Description | |
---|---|---|
clone(): ModelClipGroup | Create a deep copy of this group. | |
includesModel(modelId: string): boolean | Returns whether the specified model Id belongs to this group. | |
toJSON(): ModelClipGroupProps | Convert to JSON representation. | |
create(clip: undefined | ClipVector, models?: Id64Array): ModelClipGroup Static | Create a new ModelClipGroup. | |
fromJSON(props: ModelClipGroupProps): ModelClipGroup Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
clip Readonly | undefined | ClipVector | The clip to apply to the group of models. | |
models Readonly | undefined | Id64Array | The Ids of the models to be clipped, or undefined if the group includes all models. |
Defined in
Last Updated: 20 June, 2023