EntityMetaData Class
Beta
Metadata for an Entity.
Implements
Methods
Name | Description | |
---|---|---|
constructor(jsonObj: EntityMetaDataProps): EntityMetaData |
Properties
Name | Type | Description | |
---|---|---|---|
baseClasses Readonly | string[] | The base class that this class is derives from. | |
customAttributes Readonly | undefined | CustomAttribute[] | The Custom Attributes for this class | |
description Readonly | undefined | string | ||
displayLabel Readonly | undefined | string | ||
ecclass Readonly | string | The Entity name | |
modifier Readonly | undefined | string | ||
properties Readonly | { T } | An object whose properties correspond by name to the properties of this class. |
Defined in
- core/common/src/EntityProps.ts Line 237
Last Updated: 20 June, 2023