ECJsNames Class
Utility to format ECProperty names according to the iTwin.js formatting rules. See also ECSQL Row Format.
Methods
Name | Description | |
---|---|---|
constructor(): ECJsNames | ||
systemPropertyToJsName(systemPropertyType: ECSqlSystemProperty): string Static | Returns the name of the specified ECSQL system property according to the | |
toJsName(propName: string, isSystemProperty?: boolean): string Static | Formats the specified ECProperty name according to the iTwin.js formatting rules. |
Defined in
- core/common/src/ECSqlTypes.ts Line 120
Last Updated: 20 June, 2023