ECSqlReader Class
Beta
Methods
Name |
Description |
|
formatCurrentRow(onlyReturnObject: boolean = false): object | any[] |
|
|
getMetaData(): Promise<QueryPropertyMetaData[]> |
|
|
getRowInternal(): any[] |
|
|
reset(options?: QueryOptions): void |
|
|
resetBindings(): void |
|
|
setParams(param: QueryBinder): void |
|
|
step(): Promise<boolean> |
|
|
toArray(): Promise<any[]> |
|
|
Properties
Name |
Type |
Description |
|
current Accessor ReadOnly |
QueryRowProxy |
|
|
done Accessor ReadOnly |
boolean |
|
|
query Readonly |
string |
|
|
stats Accessor ReadOnly |
QueryStats |
|
|
Defined in
Last Updated:
20 June, 2023