GeometryStreamBuilder Class
GeometryStreamBuilder is a helper class for populating the GeometryStreamProps array needed to create a GeometricElement or GeometryPart.
Methods
Name | Description | |
---|---|---|
constructor(): GeometryStreamBuilder | ||
appendBRepData(brep: BRepEntity.DataProps): boolean | Append BRepEntity.DataProps supplied in either local or world coordinates to the GeometryStreamProps array | Beta |
appendGeometry(geometry: GeometryQuery): boolean | Append a GeometryQuery supplied in either local or world coordinates to the GeometryStreamProps array | |
appendGeometryParamsChange(geomParams: GeometryParams): boolean | Change GeometryParams for subsequent geometry. | |
appendGeometryPart2d(partId: string, instanceOrigin?: Point2d, instanceRotation?: Angle, instanceScale?: number): boolean | Append a GeometryPart instance with relative position, orientation, and scale to a GeometryStreamProps array for creating a GeometricElement2d. | |
appendGeometryPart3d(partId: string, instanceOrigin?: Point3d, instanceRotation?: YawPitchRollAngles, instanceScale?: number): boolean | Append a GeometryPart instance with relative position, orientation, and scale to a GeometryStreamProps array for creating a GeometricElement3d. | |
appendGeometryRanges(): void | Store local ranges in GeometryStream for all subsequent geometry appended. | |
appendImage(image: ImageGraphic): boolean | Append an ImageGraphic supplied in either local or world coordinates. | |
appendSubCategoryChange(subCategoryId: string): boolean | Change SubCategory or reset to SubCategoryAppearance for subsequent geometry. | |
appendTextString(textString: TextString): boolean | Append a TextString supplied in either local or world coordinates to the GeometryStreamProps array | |
setLocalToWorld(localToWorld?: Transform): void | Supply optional local to world transform. | |
setLocalToWorld2d(origin: Point2d, angle: Angle = ...): void | Supply local to world transform from a Point2d and optional Angle. | |
setLocalToWorld3d(origin: Point3d, angles: YawPitchRollAngles = ...): void | Supply local to world transform from a Point3d and optional YawPitchRollAngles. | |
setLocalToWorldFromPlacement(props: PlacementProps): void | Supply local to world transform from a PlacementProps2d or PlacementProps3d. |
Properties
Name | Type | Description | |
---|---|---|---|
geometryStream Readonly | GeometryStreamProps | GeometryStream entries | |
isViewIndependent Accessor | boolean | Controls whether or not the geometry in the stream should be displayed as view-independent. |
Defined in
Last Updated: 20 June, 2023