GeometryStreamEntryProps Interface
Allowed GeometryStream entries - should only set one value.
see GeometryStream
extensions
Extends
- GeometryProps
Properties
Name | Type | Description | |
---|---|---|---|
appearance | undefined | GeometryAppearanceProps | ||
brep | undefined | BRepEntity.DataProps | ||
fill | undefined | AreaFillProps | ||
geomPart | undefined | GeometryPartInstanceProps | ||
header | undefined | GeometryStreamHeaderProps | ||
image | undefined | ImageGraphicProps | ||
material | undefined | MaterialProps | ||
pattern | undefined | AreaPattern.ParamsProps | ||
styleMod | undefined | LineStyle.ModifierProps | ||
subRange | undefined | Readonly<WritableLowAndHighXYZ> | ||
textString | undefined | TextStringProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc | ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | GeomJson.GeometryProps | {arc:...} |
bagofCurves | undefined | [CurveCollectionProps] | GeomJson.GeometryProps | A collection of curves with no required structure or connections: |
bcurve | undefined | BcurveProps | GeomJson.GeometryProps | {bcurve:...} |
box | undefined | BoxProps | GeomJson.GeometryProps | {box:...} |
bsurf | undefined | BSplineSurfaceProps | GeomJson.GeometryProps | {bsurf:...} |
cone | undefined | ConeProps | GeomJson.GeometryProps | {cone:............} |
cylinder | undefined | CylinderProps | GeomJson.GeometryProps | {cylinder:...} |
indexedMesh | undefined | IndexedMeshProps | GeomJson.GeometryProps | {indexedMesh:...} |
interpolationCurve | undefined | InterpolationCurve3dProps | GeomJson.GeometryProps | `{interpolationCurve:...}~ |
lineSegment | undefined | [XYZProps, XYZProps] | GeomJson.GeometryProps | {lineSegment:...} |
lineString | undefined | XYZProps[] | GeomJson.GeometryProps | {lineString:...} |
linearSweep | undefined | LinearSweepProps | GeomJson.GeometryProps | {linearSweep:.........} |
loop | undefined | [CurvePrimitiveProps] | GeomJson.GeometryProps | {loop:...} |
parityRegion | undefined | [{ loop: [CurvePrimitiveProps] }] | GeomJson.GeometryProps | {parityRegion:...} |
path | undefined | [CurvePrimitiveProps] | GeomJson.GeometryProps | A sequence of curves joined head to tail: |
point | undefined | XYZProps | GeomJson.GeometryProps | {point:...} |
rotationalSweep | undefined | RotationalSweepProps | GeomJson.GeometryProps | {rotationalSweep:...} |
ruledSweep | undefined | RuledSweepProps | GeomJson.GeometryProps | {ruledSweep:...} |
sphere | undefined | SphereProps | GeomJson.GeometryProps | {sphere:............} |
torusPipe | undefined | TorusPipeProps | GeomJson.GeometryProps | {torusPipe:............} |
transitionSpiral | undefined | TransitionSpiralProps | GeomJson.GeometryProps | {transitionSpiral:...} |
unionRegion | undefined | [PlanarRegionProps] | GeomJson.GeometryProps | {unionRegion:...} |
Defined in
Last Updated: 20 June, 2023