AreaPattern.ParamsProps Interface
Definition of a hatch, cross-hatch, or area pattern that can be applied to the interior of a planar region.
Properties
Name | Type | Description | |
---|---|---|---|
angle1 | undefined | AngleProps | Angle of first set of parallel lines in a hatch pattern or area pattern tile direction, 0.0 if undefined | |
angle2 | undefined | AngleProps | Angle of second set of parallel lines in a cross-hatch, 0.0 if undefined | |
color | undefined | number | Pattern color, leave undefined to inherit color from parent element. | |
defLines | undefined | AreaPattern.HatchDefLineProps[] | Define an area pattern by supplying hatch line definitions instead of using a GeometryPart | |
invisibleBoundary | undefined | boolean | Set to inhibit display of pattern boundary, not applicable when boundary is also filled, false if undefined | |
origin | undefined | XYZProps | Pattern offset (relative to placement), 0.0,0.0,0.0 if undefined | |
rotation | undefined | YawPitchRollProps | Pattern orientation (relative to placement), 0.0,0.0,0.0 if undefined | |
scale | undefined | number | Scale to apply to area pattern symbol, 1.0 if undefined | |
snappable | undefined | boolean | Set to allow snapping to pattern geometry, false if undefined | |
space1 | undefined | number | Spacing of first set of parallel lines in a hatch pattern, or row spacing between area pattern tiles, 0.0 if undefined | |
space2 | undefined | number | Spacing of second set of parallel lines in a cross-hatch (leave undefined or 0 for a hatch), or column spacing between area pattern tiles, 0.0 if undefined | |
symbolId | undefined | string | GeometryPart id to use for tiled area pattern display | |
weight | undefined | number | Pattern weight, leave undefined to inherit weight from parent element. |
Defined in
Last Updated: 20 June, 2023