AreaFillProps Interface
Add a AreaFillProps.gradient, AreaFillProps.backgroundFill, or solid AreaFillProps.color fill to subsequent planar regions (or meshes). Only one value among AreaFillProps.gradient, AreaFillProps.backgroundFill, and AreaFillProps.color should be set.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
backgroundFill | undefined | BackgroundFill | Set fill color to view background color. | |
color | undefined | number | Set fill color to a specific color. | |
display | FillDisplay | Fill display type, must be set to something other than FillDisplay.Never to display fill | |
gradient | undefined | Gradient.SymbProps | Set fill using gradient properties. | |
transparency | undefined | number | Optional fill transparency, will be the same as outline transparency if undefined. |
Defined in
Last Updated: 20 June, 2023