Gradient.SymbProps Interface
Multi-color area fill defined by a range of colors that vary by position
Properties
Name | Type | Description | |
---|---|---|---|
angle | undefined | AngleProps | Gradient rotation angle, 0.0 if undefined | |
flags | undefined | Gradient.Flags | Gradient flags to enable outline display and invert color fractions, Flags.None if undefined | |
keys | Gradient.KeyColorProps[] | Gradient fraction value/color pairs, 1 minimum (uses tint for 2nd color), 8 maximum | |
mode | Gradient.Mode | Gradient type, must be set to something other than Gradient.Mode.None to display fill | |
shift | undefined | number | Gradient shift value from 0.0 to 1.0, 0.0 if undefined | |
thematicSettings | undefined | ThematicGradientSettingsProps | Settings applicable to ThematicDisplay. | |
tint | undefined | number | Gradient tint value from 0.0 to 1.0, only used when Gradient.KeyColorProps size is 1, 0.0 if undefined |
Defined in
- core/common/src/Gradient.ts Line 69
Last Updated: 20 June, 2023